Problemas con imagenes (thumbnails)

Inicio Foros Ayuda WordPress Problemas con imagenes (thumbnails)

Etiquetado: , ,

Mostrando 5 respuestas a los debates
  • Autor
    Publicar
    • #418
      Jacqueline
      Participant

      Hola amigos de wordpress chile:

      Es primera vez que escribo al foro. Les cuento que he desarrollado un sitio en wordpress que ultimamente he tenido algunos inconvenientes con las imagenes.

      He buscado por internet las posibles causas como para solucionar el inconveniente pero mucho exito no he tenido :(, he aprendido mucho wordpress por mi cuenta como al igual que todos ustedes pero este tema de las imagenes me esta ganando.

      Si algunos de ustedes quisiera y pudieran orientarme estare eternamente agradecida.

      Les cuento puntualmente mi problema:

      Si entran al sitio http://www.oaa.cl en la seccion fotos observatorio de la seccion del menú galeria, se vera una secuencia de imagenes que cambia cada aprox. 4 segundos, en la parte superior a la derecha donde estan los iconos de las redes sociales aparece un icono que es un cuadrado que al hacer clic alli aparece en la parte inferior del sitio una hilera donde debieran verse las mismas imagenes pero pequeñas, cosa que no sucede en mi caso.

      Cuando desarrolle primero el sitio en el servidor local al subir las imagenes las alojaba en: localhost/oaanuevo/wp-content/uploads/2011/11 y cuando accedia a ver el sitio se veian todas las imagenes, tanto las pequeñas como las grandes. Cuando migre el sitio al servidor donde esta alojada la pagina actualmente, en principio, no se veia nada (ni imagenes grandes ni pequeñas) por lo que decidi crear la galeria de nuevo y al subir imagenes me las aloja en http://www.oaa.cl/wp-content/uploads/2011/12 es decir en vez de la carpeta 11 las guarda en la carpeta 12 ¿tendra relación eso para que las imagenes pequeñas no se vean?

      El otro detalle es que en el caso de navegadores web como chrome, cuando una imagen no se ve aparece un cuadradito pequeñito al igual que una x en el caso de IE, si hago clic derecho para ver imagen no me aparece nada pero en la barra de direccion me aparece una ruta extraña que es algo asi para el caso de una imagen http://www.oaa.cl/wp-content/themes/dk/thumb.php?src=http://www.oaa.cl/wp-content/uploads/2011/12/ambiente-rustico-.jpg&w=162&zc=1&q=80&bid=1 en donde hace referencia al archivo thumb.php, tal vez de ahi proviene el problema pero revise ese archivo y como no se mucho php para mi ha sido dificil encontrar si hay un error o no.

      Para mas remate hoy he ingresado al sitio pero si hago clic derecho en una “imagen pequeña” para ver la ruta no me da la opción de “ver imagen en nueva pestaña” asi que ya no puedo ver con detalle la ruta que siguen las imagenes pequeñas como para encontrar el error que no me permite visualizarlas.

      Y asi….se que he sido muy extensa pero estoy preocupada 🙁

      Espero que puedan orientarme, disculpandome por posibles molestias ocasionadas.

      Gracias a todos por el tiempo en leer este post y la ayuda que me puedan dar.

      Saludos

      Mintaka

    • #693
      DoctorPC
      Moderator

      Si no me equivoco desde la 286 parten las miniaturas:

      {image : ‘http://www.oaa.cl/wp-content/uploads/2011/12/ambiente-rustico.jpg&#8217;, thumb: ‘http://www.oaa.cl/wp-content/themes/dk/timthumb.php?src=http://www.oaa.cl/wp-content/uploads/2011/12/ambiente-rustico.jpg&h=80&w=130&zc=1&#8217;, title: “<div id=”gallery_title”>Ambiente Rústico</div><div id=”gallery_desc”></div>”}

      Se ve que está buscando el recurso a http://www.oaa.cl/wp-content/uploads/2011/12/ambiente-rustico.jpg Que si existe.

      Para ver el código (IE) barra de menú, ingresa a Ver -> Código fuente.

      Mi duda es decir: “Cuando migre el sitio al servidor”. ¿Migrar es sacar el archivo de exportación en XML?

      La otra pregunta es si ¿estás usando la galería de WordPress o algún plugin para galería? A simple vista creo que es un extra de la plantilla.

      Si subiste la carpeta de imágenes “a la mala” (copiar y pegar) y sólo el archivo XML con el resto, puede ser ese el problema.

      Nunca me han gustado las plantillas con imágenes por esta clase de problemas, entre que funcionen para todos los navegadores, que sale una actualización y la galería desaparece, etc.

      Pero si puedes responder estas dudas, podemos aconsejarte mejor, Saludos!

    • #694
      Cristián Murillo
      Participant

      Respecto a:

      “al subir imagenes me las aloja en http://www.oaa.cl/wp-content/uploads/2011/12 es decir en vez de la carpeta 11 las guarda en la carpeta 12 ¿tendra relación eso para que las imagenes pequeñas no se vean?”

      Cada vez que subes una imagen (u otro archivo de medios), los subirá a una carpeta correspondiente al mes: [url-wp]/wp-content/uploads/[año]/[mes]

      Como el tema que usas es de ThemeGoods, si lo compraste tienes derecho a soporte en http://support.themegoods.com

      En todo caso quizá te sirva el tip en http://support.themegoods.com/?knowledgebase=images-not-displaying — básicamente dice que tu carpeta “cache” debe tener permisos de escritura (chmod 777) y la carpeta del tema ( [url-wp]/wp-content/themes/dk ) tiene que tener permisos 755. Si tienes acceso FTP o FTP, con tu cliente FTP puedes ver/modificar permisos de archivos y carpetas (puede que en tu caso sea algo como clic derecho sobre la carpeta remota, Info > Permisos).

      A veces ayuda también el plugin “Regenerate Thumbnails”.

      Saludos.

    • #695
      Jacqueline
      Participant

      Hola!!!

      Gracias por sus respuestas, disculpen si no había dado respuesta antes pero estaba fuera de stgo.

      Doctor pc: al decir migrar me refiero que traslado el sitio wordpress con todos sus archivos y la base de datos que tenia en el servidor local de mi pc (ya que primero hice el sitio en un servidor local)a un servidor que pague para que hospede el sitio.

      Lo que mencionaste: “Si subiste la carpeta de imágenes “a la mala” (copiar y pegar) y sólo el archivo XML con el resto, puede ser ese el problema.”

      No entiendo mucho que quieres decir :S, solo se que mediante un ftp traslade desde mi pc al servidor que contrate las carpetas wp-admin, wp-content y wp-include y el resto de los archivos php inluyendo el xml ademas de exportar la base de datos que estaba en el servidor local (xampp para linux) para luego en el hosting importar el archivo sql.

      En cuanto a la galeria, tengo 2 galerias una que instale mediante un plugin pero con esa no tengo problemas ya que funciona bien, con la que tengo problemas es con la galeria que venia con el template incorporado.

      Cristian: Es interesante lo que dices puesto que en el servidor local de mi pc (xampp para linux) al acceder al wordpress y ver la url de las imágenes muestran que están en la carpeta 11 y las imágenes se ven, mientras que en servidor que contrate las imágenes están en la carpeta 12 y las imágenes no se ven… curioso no?? como poder hacer que las imágenes estén en la carpeta 11 y no en la 12 y que las url de las imágenes dirijan a la carpeta 11??

      Lo otro es que ya he visto casi todos los foros e incluso ese que me indicas pero no se mucho ingles y aunque hay traductores online me cuesta mucho aveces entender o interpretar las respuestas que hay así que como quedo igual en la duda 😛

      También probé con los permisos y nada… 🙁

      Veré que tal suerte tengo con el plugin que mencionas y les cuento como me fue.

      Gracias por sus ayudas..

      Saludos.

      Mintaka 😉

    • #696
      Jacqueline
      Participant

      Me fue mal con el plugin “Regenerate Thumbnails” , lo instale y regenero las imagenes pero sigue el mismo problema al entrar al sitio… 🙁

      Cual sera el problema.??????

      Gracias por sus respuestas

      Saludos

      Mintaka 😉

    • #697
      f0rest
      Keymaster

      Verificaste si existe alguna carpeta llamada cache?

      y tienes los permisos 777 correspondientes??

      A veces suele suceder solo por eso

      en caso que no te generen automaticamente los thumbnails es posible que debas desactivar algunos parámetros del mod_security de tu proveedor de hosting

Mostrando 5 respuestas a los debates
  • Debes estar registrado para responder a este debate.